jasonloong.com Forums

LibreNMS and Raspberry Pi

Next question. I’ve installed and configured snmpd on a few Pi’s and all that nms seems to get is basic info from them. No cpu, mem or storage stats. All the graphs say “Error Drawing Graph”

The only changes I’ve made to snmpd.conf are
agentAddress udp:161 or just agentAddress 161 and
rocommunity public 190.0.10.0/24 or just rocommunity public

I’ve added a couple Ubiquiti devices and they seem fine.

Give it some time to generate the graphs :star_struck: they need to collect data first

Try above post for the RPi, didn’t try on my RPi as its just for pure testing

If you want to make sure snmpd works

cd /etc/snmp/

# backup initial default snmpd.conf
mv snmpd.conf snmpd.conf.bck

nano snmpd.conf

In the new snmpd.conf, you can have just this one line of config
rocommunity pass_phrase

Exit, Save, issue a restart to the snmpd service

systemctl restart snmpd

Check to see whether it has been started successfully

systemctl status snmpd

Check via Terminal

In your LibreNMS container bash
docker exec -it librenms bash

Run a snmpwalk to the device (substitute whether its v2c or v1 protocol)
snmpwalk -v 2c -c your-community-passphrase IP.HERE

Check via GUI (LibreNMS)

After you have added the Device, run some pre-checks to make sure Libre is able to discover the device

In your Device details page, middle right Gear Icon

Issue captures on all tabs, you should see lots of numbers, that means it has successfully polled data from your device via a manual snmpwalk (via the GUI)

They have been running since Friday evening. :slight_smile:

No idea there, just assuming, since there’s no indication that you have succeeded on Friday :smiley:

Anyway, I’m running a test on an RPi, everything seem to work. Getting the CPU/RAM/HDD

snmpd installation

sudo apt install snmpd -y

LibreNMS on the same test container that we tested

Try setting the config file with a bare minimum, if that works, at least we know the problem lies in setting up snmpd.conf

Note: remember to restart snmpd , it has happened to me a few times :rofl:

That worked.
Put just a single entry in the snmpd.conf.

Thanks!

Next…

Glad it worked! :grin: you should revisit the snmpd config if you are worried about security. It’s usually ok as long as it’s local